de74291943de96b01ad6bc96f8c06117e1efffee
[svn42.git] / old-door-deamon / libparportled-0.5.1 / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 # This is the debhelper compatibility version to use.
7 export DH_COMPAT=4
8
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13
14
15 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
16         CFLAGS += -g
17 endif
18 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
19         INSTALL_PROGRAM += -s
20 endif
21
22 # shared library versions, option 1
23 version=2.0.5
24 major=2
25 # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
26 #version=`ls src/.libs/lib*.so.* | \
27 # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
28 #major=`ls src/.libs/lib*.so.* | \
29 # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
30
31 config.status: configure
32         dh_testdir
33         # Add here commands to configure the package.
34         ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
35
36
37 build: build-stamp
38 build-stamp:  config.status
39         dh_testdir
40
41         # Add here commands to compile the package.
42         $(MAKE)
43
44         touch build-stamp
45
46 clean:
47         dh_testdir
48         dh_testroot
49         rm -f build-stamp 
50
51         # Add here commands to clean up after the build process.
52         -$(MAKE) distclean
53         -test -r /usr/share/misc/config.sub && \
54           cp -f /usr/share/misc/config.sub config.sub
55         -test -r /usr/share/misc/config.guess && \
56           cp -f /usr/share/misc/config.guess config.guess
57
58
59         dh_clean
60
61 install: build
62         dh_testdir
63         dh_testroot
64         dh_clean -k
65         dh_installdirs
66
67         # Add here commands to install the package into debian/tmp
68         $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
69
70
71 # Build architecture-independent files here.
72 binary-indep: build install
73 # We have nothing to do by default.
74
75 # Build architecture-dependent files here.
76 binary-arch: build install
77         dh_testdir
78         dh_testroot
79         dh_movefiles
80
81 #       dh_installdebconf       
82         dh_installdocs
83         dh_installexamples
84 #       dh_installmenu
85 #       dh_installlogrotate
86 #       dh_installemacsen
87 #       dh_installpam
88 #       dh_installmime
89 #       dh_installinit
90 #       dh_installcron
91 #       dh_installman
92 #       dh_installinfo
93 #       dh_undocumented
94         dh_installchangelogs 
95         dh_link
96         dh_strip
97         dh_compress
98         dh_fixperms
99         dh_makeshlibs
100         dh_installdeb
101 #       dh_perl
102         dh_shlibdeps
103         dh_gencontrol
104         dh_md5sums
105         dh_builddeb
106
107 binary: binary-indep binary-arch
108 .PHONY: build clean binary-indep binary-arch binary install