55a9a0b584e936b368ca3f5da8e2f2af32f8c737
[svn42.git] / old-door-deamon / ledstats-0.3.1 / debian / rules
1 #!/usr/bin/make -f
2 # Uncomment this to turn on verbose mode.
3 #export DH_VERBOSE=1
4
5 # This is the debhelper compatibility version to use.
6 export DH_COMPAT=4
7
8 # These are used for cross-compiling and for saving the configure script
9 # from having to guess our platform (since we know it already)
10 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
12
13
14 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
15         CFLAGS += -g
16 endif
17 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
18         INSTALL_PROGRAM += -s
19 endif
20
21 config.status: configure
22         dh_testdir
23         # Add here commands to configure the package.
24         ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
25
26
27 build: build-stamp
28
29 build-stamp:  config.status
30         dh_testdir
31
32         # Add here commands to compile the package.
33         $(MAKE)
34         #/usr/bin/docbook-to-man debian/ledstats.sgml > ledstats.1
35
36         touch build-stamp
37
38 clean:
39         dh_testdir
40         dh_testroot
41         rm -f build-stamp 
42
43         # Add here commands to clean up after the build process.
44         -$(MAKE) clean
45         -test -r /usr/share/misc/config.sub && \
46           cp -f /usr/share/misc/config.sub config.sub
47         -test -r /usr/share/misc/config.guess && \
48           cp -f /usr/share/misc/config.guess config.guess
49
50
51         dh_clean
52
53 install: build
54         dh_testdir
55         dh_testroot
56         dh_clean -k
57         dh_installdirs
58
59         # Add here commands to install the package into debian/ledstats.
60         $(MAKE) install prefix=$(CURDIR)/debian/ledstats/usr
61
62
63 # Build architecture-independent files here.
64 binary-indep: build install
65 # We have nothing to do by default.
66
67 # Build architecture-dependent files here.
68 binary-arch: build install
69         dh_testdir
70         dh_testroot
71 #       dh_installdebconf       
72         dh_installdocs
73 #       dh_installexamples
74 #       dh_installmenu
75 #       dh_installlogrotate
76 #       dh_installemacsen
77 #       dh_installpam
78 #       dh_installmime
79         dh_installinit
80 #       dh_installcron
81 #       dh_installman
82 #       dh_installinfo
83 #       dh_undocumented
84         dh_installchangelogs 
85         dh_link
86         dh_strip
87         dh_compress
88         dh_fixperms
89 #       dh_makeshlibs
90         dh_installdeb
91 #       dh_perl
92         dh_shlibdeps
93         dh_gencontrol
94         dh_md5sums
95         dh_builddeb
96
97 binary: binary-indep binary-arch
98 .PHONY: build clean binary-indep binary-arch binary install